Как подключить jQuery к blogger/blogspot

Нужно знать всем.


Вставляем до тега /head захостенный скрипт библиотеки:
Если у вас есть хостинг, кладите на свой.

21 комментарий:

  1. а зачем он нужен в блогспоте?

    ОтветитьУдалить
  2. На основе этой библиотеки работает очеь много нужных вещей в блогах, особенно таких, как Blogger, где язык php не используется.
    На jquery сделаны галереи, реализованы анимация, украшения, навигация для сайтов, различные меню и много всего другого.

    Когда я писал этот пост, то не собирался вести полноценный блог. Мне нужно было для форума блогеров (bloggerforum.ru), на котором тогда случайно зацепился, выложить несколько описаний скриптов. Поэтому первые посты в блоге сверх лаконичные.

    Сейчас бы я дописал, что jquery и другие библиотеки можно и надёжнее использовать с Яндекса (http://api.yandex.ru/jslibs/libs.xml, на котором для этих целей они и выложены.

    ОтветитьУдалить
  3. А обязательно его скрипт ложить на свой хостинг?

    ОтветитьУдалить
  4. Конечно нет. Эта ссылка ведёт к офоициальному серверу, не думаю, что с ним может что-то произойти.

    Перекладывается скрипт на свой хостинг чисто ради удобства. Если у вас несколько проектов или даже 10, то так легче вести учёт используемых скриптов. И ещё одна деталь: Яндекс больше любит, когда ссылки ведут на русские хосты. Но это уже мелочи.

    ОтветитьУдалить
  5. @aldous

    т.е. вы имеете ввиду, что вместо того адреса, который вы поставили можно поставить один из адресов в списке Яндекса?

    т.е. если установить эту jquery - то что дальше делать? как устанавливать остальные дела? украшения, навигацию и т.д. об этом вы пишете?

    ОтветитьУдалить
  6. Да, с Яндекса - гарантия надёжности.
    По поводу остальных дел - тег jquery, где больше 50-ти постов на эту тему :).

    ОтветитьУдалить
  7. Огромное спасибо! Ваши посты отлично помогают:)

    ОтветитьУдалить
  8. Ок. Предположим я подключил JQuery. И скачал себе скрипт отправки сообщений. Куда вставлять этот скрипт?

    ОтветитьУдалить
  9. Куда требует инструкция. Всё зависит от того, что это за скрипт, и где он будет применяться. Blogspot, что ценно, позволяет вставлять скрипты прямо на страницы, включая статические.

    ОтветитьУдалить
  10. По большому счету нужно прописать путь к файлам. Но пока не могу понять как)))

    ОтветитьУдалить
  11. В Blogger пока нет хостинга (может после запуска нового сервиса от Google он появится), поэтому нужно использовать внешний хостинг (арендованный или бесплатный, типа Dropbox и Google Code), положить туда файлы (стили css, скрипты и т.п.), а в блоге прописывать путь к ним.

    ОтветитьУдалить
  12. Анонимный28 июля 2012 г., 21:06

    с такими типами блогов, как мой http://www.topdjays.blogspot.com этот qJerry не работает(( У меня слайдеры на home-станице... А ведь столько всего можно было бы сделать... А есть что-то типа подобного?

    ОтветитьУдалить
  13. Предпочитаю вставлять так скажем самообновлямеый код для jquery, http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js Единственный минус, если jquery используется, к примеру, слайдером, то при обновлении скрипта слайдер может дать сбой по причине несовместимости.

    ОтветитьУдалить
  14. вот я так и думал, я поменял свою ссылку http://apis.google.com/js/plusone.js на вашу, и слайд сразу остановился...(( Наверно шаблон поменяю, хотя я его так раскрутил...В общем, не знаю как поступить, а ещё случайно ничего похожего нет?(

    ОтветитьУдалить
  15. @DesiredНасколько знаю, plusone.js это скрипт кнопки гугл+. Если нужно добавить jQuery то его и добавляй. И шаблон здесь не причем.

    ОтветитьУдалить
  16. Всё равно вставляю этот jQuery - код, не удаляя plusone.js, и слайдер сразу останавливается(

    ОтветитьУдалить
  17. @Desired насколько вижу у тебя уже стоит jQuery по ссылке https://ajax.googleapis.com/ajax/libs/jquery/1.5.1/jquery.min.js попробуй именно ее заменить на http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js Будет версия 1.7.2 стоять. Если слайдер не заработает не парься, оставь все как есть и шаблон из-за этого менять не стоит. Просто слайдер не совместим с новой версией jQuery.

    ОтветитьУдалить
  18. А в чём проблема? Слайдер работает с 1.5, но причём здесь plusone.js?

    ОтветитьУдалить
  19. Подскажите как поставить такой слайдер (который на главной странице) http://www.flowslider.com/ библиотеку jQuery уже подключил

    ОтветитьУдалить
    Ответы
    1. Как обычно - код вставить в шаблон, картинки в пикасу, переписать пути в CSS блога. Рекомендую для начала ознакомиться с азами html&css вёрстки.

      Удалить